Trading Off Charts Problem

Post any software related questions or comments here. This is also the place to ask for help if you can't figure out how to do something in Wave59.
Post Reply
abacaba
Posts: 110
Joined: Sat Aug 15, 2015 5:02 pm
Contact:

Trading Off Charts Problem

Post by abacaba » Wed Jun 17, 2020 8:20 pm

Hi Earik,

My Trading Off Chart feature, which I dearly love, is acting up. Orders will go through IB to both enter and close a position when using the standard horizontal red or blue line to set the level for the trigger. But after a fill, the red line remains on the chart and does not go away even after the position is closed. Also, when a position is on, the "get flat" button will not work and doesn't recognize any active position. Any ideas on what might be up? The ghost of Pythagoras?

Thanks as always.

Todd

User avatar
earik
Site Admin
Posts: 392
Joined: Mon Dec 01, 2014 12:41 pm
Contact:

Re: Trading Off Charts Problem

Post by earik » Wed Jun 24, 2020 9:41 pm

Does "Mercury Retrograde" count as an answer? :oops:

I'm trying to figure this out. I think the older component I've been using this whole time might have gotten broke by a new API release from IB. I can't reproduce it, but that's sort of what it sounds like. If this corrects itself magically, that means there was an issue with the order numbers (which can happen with multiple trading programs open, etc), but you've been on this long enough that I doubt it's something so simple...

Earik

abacaba
Posts: 110
Joined: Sat Aug 15, 2015 5:02 pm
Contact:

Re: Trading Off Charts Problem

Post by abacaba » Thu Jun 25, 2020 10:21 pm

Right -- it "feels" like an API issue. Things as they are are not insurmountable, but that of course adds to the pointing and clicking burden of daily trading.

Best of luck with this!

Todd

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest